+ Le chant du vario +

Forum de parapente

20 Août 2019 - 21:19:20 *
Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre mot de passe ?
Avez-vous perdu votre courriel d'activation?

Connexion avec identifiant, mot de passe et durée de la session
  Site   forum   Aide Groupes Calendrier Identifiez-vous Inscrivez-vous        GPS2GE Balises  
CSC
Pages: 1 ... 66 67 [68] 69 70 ... 77   Bas de page
  Envoyer ce fil  |  Imprimer  
Auteur Fil de discussion: DIY GnuVario : variomètre opensource - openhardware Arduino  (Lu 135573 fois)
0 Membres et 1 Invité sur ce fil de discussion.
josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1675 le: 23 Février 2019 - 20:56:55 »

Merci pour ces conseils. Comment on fait pour bypasser les deux résistances ?
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1676 le: 23 Février 2019 - 21:04:11 »

A priori ca peut marcher sans bypasser les deux résistances Clin d'oeil

Connecte juste AD0 a GND et NCS a PS.

Et dis moi si ça change quelques chose très heureux
Signaler au modérateur   parapente Enregistrée

josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1677 le: 24 Février 2019 - 13:26:39 »

La modif est faite, j'attends le froid...
Signaler au modérateur   parapente Enregistrée
josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1678 le: 24 Février 2019 - 18:42:30 »

Après quelques heures dans le congélateur à -20°C et bien je peux dire que c'est un succès! l'écran est très lent à cette température, mais ça marche!  dent
Merci!
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1679 le: 24 Février 2019 - 19:22:53 »

Alors là ! Si on a enfin trouvé la solution je suis trop content  sautillant

Je mettrais ces connexions dans la prochaine version du PCB Clin d'oeil

Effectivement notre ami Allemand avait constaté qu’une simple perturbation de ces pins pouvait faire bugger le vario  Shocked

Sur le combo ms5611+mpu9250 ils ont oublié de mettre une resistance pull-up et une résistance pull-down.
Signaler au modérateur   parapente Enregistrée

josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1680 le: 06 Mars 2019 - 19:08:40 »

Bonsoir,
J'ai voulu mettre la dernière version de jpg63 et lorsque je compile j'ai l'erreur suivante:

variometer:11:21: error: toneHAL.h: No such file or directory

Pourtant dans le dossier librairies j'ai bien le répertoire tonehal et le fichier tonehal.h

Qu'en pensez vous?
Merci
Signaler au modérateur   parapente Enregistrée
jpg63
zéroteur (se)
****
Hors ligne Hors ligne

Aile: Mac-Para ELAN
pratique principale: vol / site
vols: 500 vols
Messages: 53



« Répondre #1681 le: 06 Mars 2019 - 19:17:14 »

josecarbon,

le nom du fichier est bien toneHAL.h avec HAL en majuscule ?
Signaler au modérateur   parapente Enregistrée

olitask
débutant(e)
**
Hors ligne Hors ligne

Aile: buzz z5
pratique principale: vol / site
vols: 400 vols
Messages: 10



« Répondre #1682 le: 06 Mars 2019 - 19:20:08 »

(@) Josécarbon
salut
J'ai déjà rencontré ce problème de "casse" : il faut aller corriger le nom des fichiers ( enlever ou mettre des majuscules/minuscules  ) dans les  .h et .cpp.

-
Citation
la librairie toneAC.h  s'ecrit quelquefois ToneAC.h ou ToneAc.h et sous linux ca ne passe pas ( case sensitive). Il faut aller renommer le  fichier et corriger dans beeper.cpp et variostat.cpp ( de mémoire)


Signaler au modérateur   parapente Enregistrée
josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1683 le: 06 Mars 2019 - 22:18:39 »

merci pour vos réponses mais je vous ai indiqué une mauvaise piste en ne prenant pas le temps de mettre les majuscules mais les fichiers les portent bien, donc ce n'est à priori pas ça  Confus
Signaler au modérateur   parapente Enregistrée
cece
Rampant
*
Hors ligne Hors ligne

Aile: sigma 10
pratique principale: cross
vols: 200 vols
Messages: 1


« Répondre #1684 le: 07 Mars 2019 - 00:23:46 »

Bonjour ,
J'ai essayé le vario gps en vol très bien mais le son du buzzer est trop faible j'ai regarder les paramètres dans le fichier variosettings.h mais j'ai l'impression qu'il est déjà à 10 🤔 alors qu'il me semble que j'avais mis 3 à la base .
 
Et 2eme question je souhaiterai couper le buzzer en l'air on m'a dit de tapoter sur la boite pour couper le son mais rien  ne se passe .
Signaler au modérateur   parapente Enregistrée
jpg63
zéroteur (se)
****
Hors ligne Hors ligne

Aile: Mac-Para ELAN
pratique principale: vol / site
vols: 500 vols
Messages: 53



« Répondre #1685 le: 07 Mars 2019 - 08:37:04 »

Et 2eme question je souhaiterai couper le buzzer en l'air on m'a dit de tapoter sur la boite pour couper le son mais rien  ne se passe .

Si tu utilise ma version "jpg63", il y a une option dans variosettings pour activer ou désactiver l'option
Signaler au modérateur   parapente Enregistrée

josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1686 le: 08 Mars 2019 - 17:24:41 »

Bonsoir,
J'ai voulu mettre la dernière version de jpg63 et lorsque je compile j'ai l'erreur suivante:

variometer:11:21: error: toneHAL.h: No such file or directory

Pourtant dans le dossier librairies j'ai bien le répertoire tonehal et le fichier tonehal.h

Qu'en pensez vous?
Merci


J'ai trouvé mon erreur, dans les préférences du compilateur le dossier spécifié n'était pas le bon...
Désolé du dérangement
Signaler au modérateur   parapente Enregistrée
GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1687 le: 10 Mars 2019 - 15:41:06 »

Au secours, i'IDE m'embète !
Je n'arrive pas à charger le nouveau bootloader dans le mini. J'ai ca:
Arduino : 1.8.8 (Windows 7), Carte : "Arduino Pro or Pro Mini, ATmega328P (3.3V, 8 MHz)"

C:\Program Files\Arduino\hardware\tools\avr/bin/avrdude -CC:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf -v -patmega328p -carduino -PCOM13 -b19200 -e -Ulock:w:0x3F:m -Uefuse:w:0xFD:m -Uhfuse:w:0xDA:m -Ulfuse:w:0xFF:m

avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "C:\Program Files\Arduino\hardware\tools\avr/etc/avrdude.conf"

         Using Port                    : COM13
         Using Programmer              : arduino
         Overriding Baud Rate          : 19200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15
Erreur lors de la gravure de la séquence d'initialisation.
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Arduino
         Description     : Arduino

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x02

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x10
         Hardware Version: 4744608
         Firmware Version: 0.4611299
         Topcard         : STK502
         Vtarget         : 1.8 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: stk500_initialize(): (b) protocol error, expect=0x10, resp=0x01
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x10

avrdude done.  Thank you.

Ce rapport pourrait être plus détaillé avec
l'option "Afficher les résultats détaillés de la compilation"
activée dans Fichier -> Préférences.

help !
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1688 le: 10 Mars 2019 - 19:01:14 »

Salut !

Je vois qu'on s'approche de la mise en forme de ton vario Clin d'oeil J'ai hate de voir ça très heureux

Voici les points à vérifier :

1) Refais la configuration de ton Arduino Programmeur :
-> Vérifies que tu as mis le bon modèle de carte et de processeur correspondant à ton Arduino programmeur.
-> Vérifies dans "Outils" que le programmeur est "AVRISP mkII".
-> Ouvre "Exemples -> ArduinoISP"
-> Compile et uploade sur ton Arduino programmeur

2) Connectes ton Arduino programmeur comme dans le tuto :
https://prunkdump.github.io/GNUVario/bootloader.html

3) Passe le pro-mini à programmer dans la broche

4) Vérifies la configuration de ton IDE :
-> Vérifies que le modèle de carte est "pro-mini" et le processeur "Atmega328P 8Mhtz 3.3V"
-> Vérifies dans "Outils" que le programmeur est "Arduino As ISP" et non pas "ArduinoISP". Je sais pas comment c'est traduit. Il faut peut-être mettre "Arduino comme ISP" et non pas "ArduinoISP".
-> Envois le bootloader.

Je pense que dans ton cas tu as oublié de modifier le "programmeur" lors de l'écriture du bootloader.

Il faut un peu forcer l'Arduino à programmer contre ses broches pour que le contact se fasse bien.

Autrement c'est qu'il te faut un condo entre RESET et GND sur l'arduino programmeur. Si tu as pas de condo tu peux en piquer un sur une autre plaque. Tu soudes deux fils dessus.

Mais vérifies bien ta configuration avant.


Bon courage Tire la langue
Signaler au modérateur   parapente Enregistrée

prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1689 le: 10 Mars 2019 - 20:40:16 »

Après vérification :

-> Le condensateur entre RESET et GND est obligatoire sur les Mega, Uno, Mini, Nano ...

-> Il n'est pas nécessaire sur les Leonardo, Esplora, Micro ...

A toi d'adapter selon ton Arduino Prorammeur.

Signaler au modérateur   parapente Enregistrée

GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1690 le: 10 Mars 2019 - 21:23:34 »

bah j'y arrive pas...
la seule différence avec ce que tu as marqué c'est : processeur Atmega328P(old bootloader), mais il n'y a que celui-ci qui fonctionne...
Et aussi j'ai mis le nouveau régulateur mais je pense pas que ca aie quelque chose a voir
pareil avec un autre nano
 fum  fum  fum
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1691 le: 11 Mars 2019 - 07:56:48 »

Salut !

Il faut que tu détailles un peu plus ce que tu fais. Peut-être que je pourrais voir un truc auquel on a pas pensé.

Par exemple expliques moi si tout s'est bien passé pour l'Upload de l'Arduino Programmateur.
-> Tu as bien mis les même paramètres que moi à part processeur Atmega328P(old bootloader) ?
-> C'est bien un Nano ? Tu ne l'as pas modifié ?
-> L'IDE te dis bien que l'upload du programme "ArduinoISP" a réussi ?

Pour le montage :
-> Comment as tu alimenté le pro-mini ? As-tu bien raccordé la pin VCC du Nano à la pin RAW du pro-mini ?
-> Vérifies la tension entre VCC et GND sur le Pro-mini lorsque tout est raccordé pour voir si il est bien alimenté et qu'il n'y a pas de problèmes avec ton régulateur.
-> As-tu bien connecté la Masse du Nano avec la Masse du Pro-mini ? Est-ce que le pro-mini démarre bien lorsque tout est connecté ?
-> As-tu bien mis le condensateur entre RESET et GND sur l'Arduino programmateur ? Selon le type de condensateur il faut parfois changer l'ordre des pins ( le retourner, changer la polarisation )

Pour l'écriture du bootloader :
-> Vérifies encore les paramètres de l'IDE. Surtout le programmeur. C'est quoi que tu choisit ? C'est écrit comment ? Vois-tu bien la distinction entre "ArduinoISP" et "Arduino As ISP" ?
-> Fais ton montage sans le connecter à l'USB et vérifies bien toutes les connections au testeur de continuité.
-> Fait bien contact sur le Pro-mini en le poussant contre la broche.

Voilà quelque idées ! Il doit bien y avoir quelque chose qui pose problème.


Signaler au modérateur   parapente Enregistrée

GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1692 le: 11 Mars 2019 - 09:36:02 »

Le flash du nano en Arduino se passe sans messages d’erreur, et oui je vois bien la différence entre Arduino as isp et Arduino isp. Le pro à modifier semble bien alimenté, j’ai même fini par souder 6 pinuches dessus !
Je vais tenter de mettre la capa dans l’autre sens, puis une autre, ça mange pas de pain.
Le truc qui me chiffonne ce matin (la nuit porte conseil c’est bien connu !) c’est que le nano est en 5 v et le pro mini en 3,3. Je connais pas les niveaux logiques de tête mais je verrais bien un truc du genre...un collègue doit me donner la réf d’un isp parametrable...
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1693 le: 11 Mars 2019 - 13:09:10 »

Pour les niveaux logiques ça ne pose pas de problèmes.

J'ai toujours fait avec une Nano 5V pour programmer un Arduino 3V. Il faut juste connecter VCC à RAW au lieu de VCC à VCC.

Le problème doit être ailleurs.
Signaler au modérateur   parapente Enregistrée

GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1694 le: 11 Mars 2019 - 14:19:11 »

La pin vcc c’est bien celle marquée 5v ?
Le truc aussi c’est que le pro soit branché ou non c’est les mêmes erreurs. Pourtant il est allumé
« Dernière édition: 11 Mars 2019 - 14:30:33 par GtD73 » Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1695 le: 11 Mars 2019 - 15:22:50 »

Je pense que le problème c'est ton condo. Soit il est trop petit soit il est polarisé et dans le mauvais sens.

Voici les différents messages d'erreurs.

1) Si le programme "ArduinoISP" n'est pas uploadé sur l'Arduino j'ai l'erreur suivante lors de la gravure du bootloader. On voit qu'il ne parvient à trouver aucune connexion à part l'USB.

Code:
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/home/prunkdump/Downloads/arduino-1.8.8/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/prunkdump/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : arduino
         Overriding Baud Rate          : 19200
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 3 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 4 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 5 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 6 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 7 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 8 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 9 of 10: not in sync: resp=0x00
avrdude: stk500_recv(): programmer is not responding
avrdude: stk500_getsync() attempt 10 of 10: not in sync: resp=0x00

avrdude done.  Thank you.

Error while burning bootloader.

2) Si le programme "ArduinoISP" est uploadé mais que le condo n'est pas correct j'ai l'erreur suivante. Elle ressemble beaucoup à la tienne. On voit qu'il trouve le Nano mais qu'il n'arrive pas a se connecter correctement dessus :

Code:
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/home/prunkdump/Downloads/arduino-1.8.8/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/prunkdump/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB0
         Using Programmer              : arduino
         Overriding Baud Rate          : 19200
avrdude: stk500_getsync() attempt 1 of 10: not in sync: resp=0x15
avrdude: stk500_getsync() attempt 2 of 10: not in sync: resp=0x15
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Arduino
         Description     : Arduino

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x14

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x02

avrdude: stk500_getparm(): (a) protocol error, expect=0x14, resp=0x10
         Hardware Version: 4238814
         Firmware Version: 23901840.0
         Topcard         : STK502
         Vtarget         : 1.8 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: stk500_initialize(): (b) protocol error, expect=0x10, resp=0x01
avrdude: initialization failed, rc=-1
         Double check connections and try again, or use -F to override
         this check.

avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x10

avrdude done.  Thank you.

Error while burning bootloader.


3) Si le condo est bien positionné et que le Pro-mini n'est pas connecté j'ai bien sur une erreur aussi. Mais on voit cette fois-ci qu'il parvient à se connecter au Nano. Regarde le message "avrdude: AVR device initialized and ready to accept instructions".

Code:
avrdude: Version 6.3-20171130
         Copyright (c) 2000-2005 Brian Dean, http://www.bdmicro.com/
         Copyright (c) 2007-2014 Joerg Wunsch

         System wide configuration file is "/home/prunkdump/Downloads/arduino-1.8.8/hardware/tools/avr/etc/avrdude.conf"
         User configuration file is "/home/prunkdump/.avrduderc"
         User configuration file does not exist or is not a regular file, skipping

         Using Port                    : /dev/ttyUSB2
         Using Programmer              : arduino
         Overriding Baud Rate          : 19200
         AVR Part                      : ATmega328P
         Chip Erase delay              : 9000 us
         PAGEL                         : PD7
         BS2                           : PC2
         RESET disposition             : dedicated
         RETRY pulse                   : SCK
         serial program mode           : yes
         parallel program mode         : yes
         Timeout                       : 200
         StabDelay                     : 100
         CmdexeDelay                   : 25
         SyncLoops                     : 32
         ByteDelay                     : 0
         PollIndex                     : 3
         PollValue                     : 0x53
         Memory Detail                 :

                                  Block Poll               Page                       Polled
           Memory Type Mode Delay Size  Indx Paged  Size   Size #Pages MinW  MaxW   ReadBack
           ----------- ---- ----- ----- ---- ------ ------ ---- ------ ----- ----- ---------
           eeprom        65    20     4    0 no       1024    4      0  3600  3600 0xff 0xff
           flash         65     6   128    0 yes     32768  128    256  4500  4500 0xff 0xff
           lfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           hfuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           efuse          0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           lock           0     0     0    0 no          1    0      0  4500  4500 0x00 0x00
           calibration    0     0     0    0 no          1    0      0     0     0 0x00 0x00
           signature      0     0     0    0 no          3    0      0     0     0 0x00 0x00

         Programmer Type : Arduino
         Description     : Arduino
         Hardware Version: 2
         Firmware Version: 1.18
         Topcard         : Unknown
         Vtarget         : 0.0 V
         Varef           : 0.0 V
         Oscillator      : Off
         SCK period      : 0.1 us

avrdude: AVR device initialized and ready to accept instructions

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x000000 (retrying)

Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x000000 (retrying)

Error while burning bootloader.
Reading | ################################################## | 100% 0.01s

avrdude: Device signature = 0x000000
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.


avrdude done.  Thank you.

Du coup je suis presque sur que c'est un problème de condo.
Signaler au modérateur   parapente Enregistrée

GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1696 le: 11 Mars 2019 - 19:19:46 »

Merci beaucoup pour ta patience !
Je suis exactement dans le cas No 2, mais que j'ai le pro mini branché ou non...
Pareil avec un autre condo.
Quand on aura trouvé je me dirais « ah oui quel con! »
Mais en attendant je vois pas.
« Dernière édition: 11 Mars 2019 - 19:41:39 par GtD73 » Signaler au modérateur   parapente Enregistrée
josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1697 le: 11 Mars 2019 - 19:50:19 »

Bonsoir,

Un problème sans doute beaucoup plus simple:
Je suis sur la version JPG et je voudrais l'affichage de la finesse et du taux de chute

J'ai mis ça  dans le variosetting.h:

// secondary display
//Display Ratio      1
//display Climb rate 2
//display both       3
#define both 3

Mais quelque soit ce que je met je n'ai toujours qu'une valeur d'affichée (le taux de chute)
j'ai essayé
#define Ratio 1

qui n'a pas fonctionné non plus

et j'ai aussi

/* the duration of the two screen pages in milliseconds */
#define VARIOMETER_BASE_PAGE_DURATION 3000
#define VARIOMETER_ALTERNATE_PAGE_DURATION 3000

Merci

Signaler au modérateur   parapente Enregistrée
jpg63
zéroteur (se)
****
Hors ligne Hors ligne

Aile: Mac-Para ELAN
pratique principale: vol / site
vols: 500 vols
Messages: 53



« Répondre #1698 le: 11 Mars 2019 - 20:03:29 »

Bonsoir,

Un problème sans doute beaucoup plus simple:
Je suis sur la version JPG et je voudrais l'affichage de la finesse et du taux de chute

J'ai mis ça  dans le variosetting.h:

// secondary display
//Display Ratio      1
//display Climb rate 2
//display both       3
#define both 3

Mais quelque soit ce que je met je n'ai toujours qu'une valeur d'affichée (le taux de chute)
j'ai essayé
#define Ratio 1

qui n'a pas fonctionné non plus

et j'ai aussi

/* the duration of the two screen pages in milliseconds */
#define VARIOMETER_BASE_PAGE_DURATION 3000
#define VARIOMETER_ALTERNATE_PAGE_DURATION 3000

Merci



il faut mettre

#define RATIO_CLIMB_RATE 3 dans variosetting.h
Signaler au modérateur   parapente Enregistrée

prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 73



« Répondre #1699 le: 11 Mars 2019 - 20:16:26 »

@josecarbon

Il faut simplement que tu changes le numéro en « 3 » comme ça :
Code:
#define RATIO_CLIMB_RATE 2

@GtD73

Quand on aura trouvé je me dirais « ah oui quel con! »
Mais en attendant je vois pas.

Pareil ! Je suis sur que c’est un truc tout bête. Mais comme je te vois pas faire il y a peut-être quelque chose qui m’echappe.

Mais bon inutile de brancher le pro-mini tant que tu n’es pas arrivé à l’etape 3). Il faut trouver ce problème avec le Condo.

-> branches uniquement le nano en USB et enleve tout le reste.
-> vérifie que le programmeur est « Arduino as ISP »
-> pour le Condo moi j’ai utilisé une plaque de charge LiPo. Y’a un Condo noté C1 dessus. J’ai coupé un fil de breadboard en 2 et j’ai soudé chaque brin d’un côté du Condo.

Ensuite je connecte l’un sur la pin Reset du Nano. L’autre fil sur la pin GND du Nano.
-> tu envoies le bootloader
-> si ça marche pas tu interverti les deux fils du Condo

Signaler au modérateur   parapente Enregistrée

Pages: 1 ... 66 67 [68] 69 70 ... 77   Haut de page
  Envoyer ce fil  |  Imprimer  
 
Aller à:  

parapente gratuit
Propulsé par MySQL Propulsé par PHP Powered by SMF 1.1.19 | SMF © 2006, Simple Machines XHTML 1.0 Transitionnel valide ! CSS valide !
Page générée en 0.04 secondes avec 23 requêtes.
anything