+ Le chant du vario +

Forum de parapente

16 Septembre 2019 - 11:10:53 *
Bienvenue, Invité. Veuillez vous connecter ou vous inscrire.
Avez-vous perdu votre mot de passe ?
Avez-vous perdu votre courriel d'activation?

Connexion avec identifiant, mot de passe et durée de la session
  Site   forum   Aide Groupes Calendrier Identifiez-vous Inscrivez-vous        GPS2GE Balises  
CSC
Pages: 1 ... 65 66 [67] 68 69 ... 79   Bas de page
  Envoyer ce fil  |  Imprimer  
Auteur Fil de discussion: DIY GnuVario : variomètre opensource - openhardware Arduino  (Lu 143116 fois)
0 Membres et 1 Invité sur ce fil de discussion.
GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1650 le: 09 Décembre 2018 - 13:06:26 »

Moi je dirais que non, à condition que tu l'utilises en vertical, genre fixé sur un élévateur
Signaler au modérateur   parapente Enregistrée
ducat
débutant(e)
**
Hors ligne Hors ligne

Aile: Infinity4 U-Turn
pratique principale: vol / site
vols: un peu ! enfin des que je peu ! vols
Messages: 13



« Répondre #1651 le: 09 Décembre 2018 - 13:43:37 »

Waouhh

suis épaté de ce que vous arrivez à faire !
Certain ressembles à du acheté en magasin…
Bon vu mon niveau en soudure  Mr. Green  si un des membre est motivé pour en faire 2 !!!
Suis preneur pour en racheter un.
ça remplacerait bien mon avantageusement mon XC trainer GPS qui est un peu encombrant et surtout qui me donne des tonnes d'infos dont je ne me sers pas !


J-F
Signaler au modérateur   parapente Enregistrée
cece
Rampant
*
Hors ligne Hors ligne

Aile: sigma 10
pratique principale: cross
vols: 200 vols
Messages: 1


« Répondre #1652 le: 09 Décembre 2018 - 15:20:16 »

Sa y ait fini j'ai sorti un connecteur avec les 2 pont et l'emplacement du FTDI
Il me reste plus qu'à remplacer le régulateur
Je suis en mode standart


* IMG_20181209_142050.jpg (47.74 Ko, 960x720 - vu 96 fois.)

* IMG_20181209_142038.jpg (43.71 Ko, 960x720 - vu 60 fois.)

* IMG_20181209_142057.jpg (45.38 Ko, 960x720 - vu 57 fois.)
Signaler au modérateur   parapente Enregistrée
olitask
débutant(e)
**
Hors ligne Hors ligne

Aile: buzz z5
pratique principale: vol / site
vols: 400 vols
Messages: 12



« Répondre #1653 le: 09 Décembre 2018 - 19:03:28 »

@cece Tant que j'y pense , il faut mettre un bout de tissus, ou de mousse sur le capteur barométrique, sinon il est beaucoup trop sensible. (perso un bout de mouchoir en papier et du scotch )
Et sinon,  Comment as tu placé ton connecteur fdti ?? J'ai pas compris avec les photos .
Signaler au modérateur   parapente Enregistrée
cece
Rampant
*
Hors ligne Hors ligne

Aile: sigma 10
pratique principale: cross
vols: 200 vols
Messages: 1


« Répondre #1654 le: 10 Décembre 2018 - 07:56:02 »

@olitask
Ok je vais faire ca !
J'ai utilisé un connecteur 8 points (avec 4 pins pour les 2 shunt et 6 pin pour le FTDI


* IMG_20181210_002852.jpg (46.34 Ko, 960x720 - vu 70 fois.)
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1655 le: 17 Décembre 2018 - 09:20:01 »

------------------------
!!! Nouvelle importante !!!
------------------------

Bonjour à tous  salut !

Vous avez pu constater récemment que plusieurs varios avaient des problèmes avec l'accéléromètre MPU9250 et des affichages complètement incohérent. Il semble qu'il y ait eu ces dernier temps un changement dans le diagramme de la plaque du ms5611+mpu9250 qui cause ces problèmes.

Notre amis allemand qui a mis en vente sa version du kit vient de me faire parvenir l'origine du probleme très heureux ( comme quoi ça sert de partager ) :

En fait la pin "AD0" du module 10DOF sert à choisir l'adresse I2C du MPU9250. Et sur les kits elle est laissée flottante. Du coup sur certaines version et dans certaines conditions ( je ne sais pas pourquoi ) l'adresse se met à changer sans raison et le vario ne peut plus communiquer avec l'accéléromètre.

Pour résoudre cela il faut relier avec une résistance 1k la pin ADO à la masse GND.

Je ne suis pas sur que la résistance soit nécessaire. Si quelqu'un arrive à le déterminer en lisant le datasheet du mpu9250 je suis preneur !!!

Il va faloir mettre à jour le PCB  Confus

A vos postes à souder Clin d'oeil !

A+
Signaler au modérateur   parapente Enregistrée

prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1656 le: 17 Décembre 2018 - 13:20:57 »

Après vérification la résistance est inutile.

Il suffit de connecter avec un fil la pin AD0 à la masse GND.


Signaler au modérateur   parapente Enregistrée

josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1657 le: 05 Janvier 2019 - 20:20:54 »

Bonjour,
Prunkdump est ce que tu penses que mes problèmes peuvent venir de là? Est ce qu'il serait possible de montrer avec une photo les pattes qu'il faut relier?
Merci
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1658 le: 06 Janvier 2019 - 09:06:38 »

C'est bien possible. Je t'invite à essayer en tout cas. Ca pourrait expliquer pourquoi il y avait tout d'un coup une série de MPU qui ne fonctionnaient pas correctement.

J'ai mis une photo en pièce jointe.

Par contre cela ne résout pas le problème du grand froid. Le vario a du mal à démarrer dans ces conditions. Il faut le chauffer un peu dans la poche avant de le démarrer. Et bizarrement après il continue de bien fonctionner.

Je n'ai pas encore compris pourquoi  hein ?

Pas facile l'électronique quand on passe a des problèmes assez technique  Clin d'oeil

Tiens nous au courant si tu vois une amélioration !

A+



* CJMCU.JPG (44.15 Ko, 400x293 - vu 49 fois.)
Signaler au modérateur   parapente Enregistrée

josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1659 le: 06 Janvier 2019 - 18:58:10 »

Merci, j'essaye et je donnerai les résultats. A bientôt.
Signaler au modérateur   parapente Enregistrée
Philgab
débutant(e)
**
Hors ligne Hors ligne

Aile: ITV Jedi2
pratique principale: cross
vols: 400 vols
Messages: 15



« Répondre #1660 le: 23 Janvier 2019 - 14:03:22 »

Bonjour à tous,
J'ai commandé tous les composants pour faire mon premier vario, et accessoirement mon premier montage avec Arduino.
J'ai tout reçu sauf le boitier qui est allé se perdre au Canada, et qui va probablement me revenir dans un mois ou 2 ... s'il revient !

Est-ce que les fichiers pour une impression 3D sont disponibles quelques part ?

PhG
Signaler au modérateur   parapente Enregistrée
guillaume1
passager biplace
*
Hors ligne Hors ligne

Aile: .
pratique principale: vol / site
vols: 150 vols
Messages: 5



« Répondre #1661 le: 28 Janvier 2019 - 19:02:53 »

bonjour

ca y est la mise a jour est faite arduino nano et tout en 5 v mais

j ai un petit soucis avec le diviseur de tension je pense  l icone batterie apparait blanc alors qu au premier ecran de demarrage  il est noir  Pleure  Pleure  Pleure

une idée ?
Signaler au modérateur   parapente Enregistrée
jpg63
zéroteur (se)
****
Hors ligne Hors ligne

Aile: Mac-Para ELAN
pratique principale: vol / site
vols: 500 vols
Messages: 61



« Répondre #1662 le: 28 Janvier 2019 - 20:39:18 »

Les résistances du diviseur de tension sont là pour abaisser la tension de la batterie à 3.3V Max. Si tu es tout en 5V, tu n'as pas besoin de pont diviseur et tu va devoir modifier le programme pour l'adapter à ton utilisation en 5V
Signaler au modérateur   parapente Enregistrée

guillaume1
passager biplace
*
Hors ligne Hors ligne

Aile: .
pratique principale: vol / site
vols: 150 vols
Messages: 5



« Répondre #1663 le: 28 Janvier 2019 - 20:50:05 »

Merci pour la reponse
Mais je me suis  branché en sorti de chargeur  donc la lipo est en 3.7v 
Apres je ne suis un pro en electro si ya moyen de m expliquer le diviseur dans le sketch  rapido

Merci  Rigole
Signaler au modérateur   parapente Enregistrée
jpg63
zéroteur (se)
****
Hors ligne Hors ligne

Aile: Mac-Para ELAN
pratique principale: vol / site
vols: 500 vols
Messages: 61



« Répondre #1664 le: 30 Janvier 2019 - 06:29:21 »

guillaume1,

j'ai regardé le code, il n'y a pas de raison, si tu utilise la bonne pin déclarée dans variosetting, le code affiche la tension mesuré à l'entrée, au pire si tu sature l'entrée tu aura tout le temps la batterie pleine, vérifie la tension et le numéro de la pin

bon courrage
Signaler au modérateur   parapente Enregistrée

josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1665 le: 03 Février 2019 - 09:19:57 »

Bonjour,
J'ai testé le branchement avec la soudure de pin AD0 à la masse GND. Pour le froid le comportement n'est je pense pas modifié. Vers 1 à 2°C l'écran est noir, vers 4 à 5° affichage des unités (m/s, m,...) mais pas des valeurs (blanc), et au dessus de 6°C tout marche...
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1666 le: 03 Février 2019 - 14:00:09 »

Et mince ....  Pleure  solution non encore trouvé du coup ...

Si tu as le courage de m'aider à chercher le problème j'aurais besoin de quelques infos.

1) Dans le code met un gros delay au début de la fonction Setup. Un truc du genre :

 
Code:
void setup() {
   delay(4000);

et regarde si ça change quelque chose.


2)  Est-ce que tu es sûr que cela vient du MPU9250 et pas de ms5611 ? As tu essayé de désactiver l'acceleromètre ? (Attention si tu fais ça tu perds la mise à jour par retournement).

Un grand merci pour ce retour en tout cas  pouce
Signaler au modérateur   parapente Enregistrée

guillaume1
passager biplace
*
Hors ligne Hors ligne

Aile: .
pratique principale: vol / site
vols: 150 vols
Messages: 5



« Répondre #1667 le: 11 Février 2019 - 20:58:57 »

guillaume1,

j'ai regardé le code, il n'y a pas de raison, si tu utilise la bonne pin déclarée dans variosetting, le code affiche la tension mesuré à l'entrée, au pire si tu sature l'entrée tu aura tout le temps la batterie pleine, vérifie la tension et le numéro de la pin

bon courrage

yes soucis trouvé  c la tension sortie du diviseur de tension 2.8v pour une batterie de 3.7 v et le code est à 3.3v
Signaler au modérateur   parapente Enregistrée
josecarbon
plouffeur(se)
***
Hors ligne Hors ligne

Aile: mentor 2
pratique principale: cross
Messages: 28


« Répondre #1668 le: 13 Février 2019 - 17:27:09 »

@prunkdump: Ok bien sur pour tester ces manip. La fonction setup elle est dans quel fichier?
je n'ai pas testé de désactiver l’accéléromètre, je le ferai.
Merci
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1669 le: 14 Février 2019 - 10:36:02 »

@josecarbon

La fonction setup est dans le fichier "variometer.ino".

Je suis en contact avec notre amis Allemand qui est bien motivé pour résoudre ce problème. Il a constaté que le problème ne se produit pas avec les plaques ms5611 et mpu9250 séparées. Il cherche avec nous d'où ça peut venir.

@guillaume1

Il ne faut pas que tu mettes de diviseur de tension. Sur un arduino 5V ce n'est pas utile. Mais on est d'accord que tu as connecté un module "step-up" qui alimente bien ta carte arduino en 5v ? Parceque tu ne peux pas brancher un Arduino 5V directement à une batterie LiPo puisqu'elle fait 4.2V max.

Pour le code. Tu met ça :

Code:
#define VOLTAGE_DIVISOR_VALUE 1.0
#define VOLTAGE_DIVISOR_REF_VOLTAGE 5.0

A+
 
Signaler au modérateur   parapente Enregistrée

GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1670 le: 19 Février 2019 - 23:39:18 »

Aaaarg bloqué à cause des buzzers qui sont coincés va savoir où...
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1671 le: 20 Février 2019 - 09:21:22 »

Ahh pas de chances ...  Confus  A un jour près j'aurais pu te les envoyer. Mais là je suis en vacances et je n'ai pas pris le matos avec moi.

Je sais pas où tu les as commandé mais en tapant sur ce site :

https://www.arrow.com/fr-fr
TE092703-6

Tu reçois d'excellents buzzers en a peine trois jours. Le prix est surement plus cher mais la qualité est incomparable. Et c'est quand même une pièce importante du vario. J'en ai commandé une dizaine pour les varios où le son était trop faible.

Et le boîtier tu as réussi à le finaliser ?

A+
Signaler au modérateur   parapente Enregistrée

GtD73
plouffeur(se)
***
Hors ligne Hors ligne

Aile: Mescal 4
pratique principale: vol / site
vols: 120 vols
Messages: 21


« Répondre #1672 le: 20 Février 2019 - 11:58:44 »

Yes j’ai commandé hier soir du coup. Pas ceux là mais chez eux. Avec des régulateurs, des résistances pour modifier la charge de la batterie que j’ai passé à 2A, et après je vais pouvoir affiner les côtes du boîtier, et partager. Ils sont long les chinois, pas cool...
Signaler au modérateur   parapente Enregistrée
prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1673 le: 20 Février 2019 - 13:30:32 »

C’est surtout que c’est le nouvel an là bas Clin d'oeil

N’oublies pas également qu’il faut changer le raccordement du ms5611 par rapport au tuto. Il faut connecter vcc à la pin STD du PCB et mettre un régulateur 3v dessus.

A+
Signaler au modérateur   parapente Enregistrée

prunkdump
zéroteur (se)
****
Hors ligne Hors ligne

Aile: ITV Dolpo 2
pratique principale: rampant passion
Messages: 74



« Répondre #1674 le: 21 Février 2019 - 12:10:19 »

Juste quelques nouvelles sur les problèmes de MPU9250 :

Il semble que le problème ne concerne que les combos MPU9250+ms5611. Le problème de froid et d'instabilité ne se produit pas avec les deux plaques séparées.

Notre amis Allemand s'est rendu compte qu'en touchant les pin AD0 ou NCS du module pendant le fonctionnement du vario le faisait bugger. Même en touchant avec un fil connecté à rien. Une simple perturbation électrique sur ces pins arrêtait la communication.

La pin AD0 sert a changer l'adresse I2C du mpu9250. La pin NCS sert a passer de la communication I2C a la communication SPI. ll est donc normal qu'une perturbation de ces pins puisse empêcher la communication.

Solution proposée :

Pour ceux qui ont des problèmes d'instabilité du MPU9250 à cause du froid ou des démarrages difficiles. Voici ce qu'il faut essayer :

1) Bypasser les deux résistances sous le ms5611. Les deux engtourées en vert sur le photo.
2) Connecter la pin AD0 à la pin GND
3) Connecter la pin NCS à la pin PS

N'hésitez pas à faire des retour si vous constatez le problème en touchant les pins ou avec le froid. Et si cette modification résout le problème.

A+
 



* bypass.JPG (81.77 Ko, 400x293 - vu 33 fois.)
Signaler au modérateur   parapente Enregistrée

Pages: 1 ... 65 66 [67] 68 69 ... 79   Haut de page
  Envoyer ce fil  |  Imprimer  
 
Aller à:  

parapente gratuit
Propulsé par MySQL Propulsé par PHP Powered by SMF 1.1.19 | SMF © 2006, Simple Machines XHTML 1.0 Transitionnel valide ! CSS valide !
Page générée en 0.027 secondes avec 23 requêtes.
anything